
Report creation activities
Try out what you’re learning as you complete the Basic Report Creation learning program 
at one.workfront.com.

To complete many of these activities, you will need access to a Workfront instance. Talk with your internal 
Workfront team to learn how to access Workfront.
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Groupings allow you to categorize and organize 
the results of a list or report.

Activity #1: Create a basic grouping
This hands-on exercise supports concepts taught in the video, Create a basic grouping.

Create an issue grouping that will be used in a report to track requests that come through a request queue. This grouping 
will make it easy to see similar types of issues/requests grouped by their priority. Name the grouping “Request Queue, 
Queue Topic, Priority.”

Group the issue report based on:

1. The name of the request queue (this will be the project name)

2. The queue topic

3. The priority of the request

Use the space below to plan out which field sources>field names you’ll use for this grouping.

Turn to the next page for the answer.
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Answer

Activity #1: Create a basic grouping

1. In an issue list report, go to the Grouping menu and select New Grouping.

2. Name your grouping “Request Queue, Queue Topic, Priority.”

3. Click Add Grouping.

4. In the First By field. type “project name” then select “Name” under the Project field source. 

5. Click Add another Grouping.

6. In the And then by field, type “queue” then select “Name” under the Queue Topic field source.

7. Click Add another Grouping.

8. In the And then by field, type “priority” then select “Priority” under the Issue field source.

9. Click Save Grouping.
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Make sure information you need to do your work 
is easy to see by creating a custom view.

Activity #2: Create a basic view
This hands-on exercise supports concepts taught in the video, Create a basic view.

As a project manager, team lead, or resource manager, you want to keep track of how task work is progressing. With this 
view, you get several status indicators of a task all in one row of the list or report.

Create a task view named “Task Status View” with the following columns:

• Task Name

• Assignments

• Duration

• Percent Complete

• Status

• Progress Status

• Status Icons

Use the space below to plan out which field sources>field names you’ll use for this view.

Turn to the next page for the answer.
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Answer

Activity #2: Create a basic view

1. In a task list report, go to the View drop-down menu and select New View.

2. Name your view “Task Status View.”

3. Remove these columns: Pln Hrs, Predecessors, Start On, and Due On.

4. Click Add Column.

5. In the Show in the column field, type “status” then select “Status” under the Task field source.

6. Click Add Column again.

7. In the Show in the column field, type “status” then select “Progress Status” under the Task field source.

8. Click Add Column again.

9. In the Show in the column field, type “status” then select “Status Icons” under the Task field source.

10. Click Save.

Hover over each of the icons in the Status Icons column to see what they represent. If they are grayed out, it means 
the task has no notes, documents, approval processes, etc. If an icon appears in color, there is at least one of that item 
associated with the task. You can click on the note or document icons to go to that item.
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Highlight information in a view based on criteria 
you establish using conditional formatting.

Activity #3: Add conditional formatting to a view
This hands-on exercise supports concepts taught in the video, Add conditional formatting to a view.

Create a task view named “Standard + Progress” by using the existing Standard view and adding this conditional 
formatting on the Name column.

1. Add a column rule that will turn the field background red when the progress status of the task is Late.

2. Add a column rule that will turn the field background yellow when the progress status is Behind or At Risk. 

This will help you spot troubled tasks without including the column for progress status as part of your view.

Use the space below to plan out the criteria you’ll use for the conditional formatting.

Turn to the next page for the answer.
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Answer

Activity #3: Add conditional formatting to a view

1. In a task list report, go to the View drop-down 
menu and select New View.

2. Name your view “Standard + Progress.”

3. Use the default columns provided.

4. Select the Task Name column. This is the column 
you want to apply the conditional formatting to, so it 
appears red or yellow if the progress status of the task 
is not On Time.

5. Click Advanced Options at the top-right corner of 
the report builder window.

6. Click Add a Rule for this Column.

7. Start the column rule by changing Task > Name at 
the top of the window to Task > Progress Status. Just 
click the X icon next to Task>Name to delete it from 
the field.

8. Type “progress” in the field, then select Progress 
Status under the Task field source.

9. Select Late in the field to the right of the Equal 
qualifier.

10. Choose a background of red in the Text Color row.

11. Click Add Rule to save the column rule.

12. Now click Add Column Rule again to add another 
rule.

13. Just like before, delete Task>Name from the 
criteria field. Replace it with Progress Status under the 
Task field source.

14. Select both At Risk and Behind in the field to the 
right of the Equal qualifier.

15. Choose a background of yellow in the Text Color 
row.

16. Click Add Rule to save the column rule.

17. Click Save View to save the view.
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Filters set the criteria for what items—projects, 
tasks, etc.—appear in the rows of the report.

Activity #4: Create a basic filter
This hands-on exercise supports concepts taught in the video, Create a basic filter.

Create a project filter named “Projects I Own Closing This Month.” If you’re keeping an eye on a lot of projects, this filter 
can help you zoom in on the ones that are planned to close soon.

Use the space below to plan out the field sources>field names and other details you’ll use for the filter.

Turn to the next page for the answer.
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Answer

Activity #4: Create a basic filter

1. Navigate to the Projects area from the Main 
Menu. This shows you a list of projects. 

2. Click the Filter menu and select New Filter.

3. Name your filter “Projects I Own Closing This 
Month.”

4. Click Add Filter Rule.

5. In the Start typing field name field, type “owner.” 
Then select Owner ID under the Project field source.

6. Leave the Equal operator as it is.

7. Type “$$” in the Start typing name field.

8. Select $$USER.ID. This is the wildcard for the 
logged-in user.

9. Click Add Filter Rule again.

10. In the Start typing field name field, start typing “Is 
Complete”. Then select Is Complete under the Project 
field source.

11. Leave the Equal operator as it is.

12. Select “False.” 

13. Click Add Filter Rule again.

14. In the Start typing field name field type “planned,” 
then select Planned Completion Date under the 
Project field source.

15. Change the Equal operator to This Month.

16. Click Save Filter.
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Combine groupings, views, and filters in a 
custom report you can run any time.

Activity #5: Create a simple task report
This hands-on exercise supports concepts taught in the video, Create a simple report.

You want to track all of your active tasks in a single report. Create a Task report named “My Current Tasks” using the 
following:

• Columns (View) = Standard

• Groupings = Project

• Filter = My Current Tasks

• Description = Incomplete tasks on Current projects where I am the task owner, grouped by project.

Use the space below to plan out the filter criteria you’ll use for this report.

Turn to the next page for the answer.
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Answer

Activity #5: Create 
a simple task report

1. Go to the Main Menu and select Reports.

2. Click the New Report drop-down menu and 
select Task Report.

3. In Columns (View), click the Apply an 
Existing View menu and select Standard.

4. In the Groupings tab, click the Apply an 
Existing Grouping menu and select Project.

5. In the Filters tab, click the Apply an Existing 
Filter menu and select My Current Tasks.

6. Open Report Settings and name the report 
“My Current Tasks.”

7. In the Description field, enter “Incomplete 
tasks on Current projects where I am the task 
owner, grouped by project.”

8. Save and Close your report.
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Prompts allow you to add more filter criteria to a 
report when you run the report.

Activity #6: Create a note report with prompts
This hands-on exercise supports concepts taught in the video, Create a task report.

Create a Note report that you can use to search for user notes (i.e., comments or updates) or system notes based on the 
note content, the author, entry date, project name, or audit type. Name the report “Note Search.”

When using the Note Text prompt, this report will search within update threads to quickly extract any that meet the 
criteria specified in the prompts. When you run the report, you don’t need to fill in every prompt, just the ones you care 
about. The blank ones are automatically ignored.

• The view should include columns for:

• Note Text

• Audit Text

• Entry Date

• Owner: Name

• Audit Type

• Task Name

• Issue Name

• Filter should be blank

• Group on Project Name

• Include prompts for the following:

• Audit Text

• Note Text

• Owner Name

• Entry Date

• Project Name

• Audit Type

Turn to the next page for the answer.
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Answer

Activity #6: Create a note report with prompts

1. Select Reports from the Main Menu.

2. Click the New Report menu and select Note.

3. In Columns (View) set up your columns to include:

• Note > Note Text

• Note > Audit Text

• Note > Entry Date

• Owner > Name

• Note > Audit Type

• Task > Name

• Issue > Name

4. Select the Entry Date column and change the Sort 
to Descending.

5. In the Groupings tab, set the report to group by 
Project > Name.

6. Leave Filters blank.

7. Open Report Settings and name the report “Note 
Search.”

8. In the Description field, put something like, “Search 
for System or User notes based on the Audit Type 
selected and other prompts. System notes appear in 
the Audit Text column and User notes appear in the 
Note Text column.”

9. Select Details Tab so that it displays when the 
report loads.

10. Set the report to show 200 items when the report 
is included on a dashboard.

11. Click Report Prompts and add:

• Note > Audit Text

• Note > Note Text

• Owner > Name

• Note > Entry Date

• Project > Name

• Note > Audit Type

12. Check the box for Show Prompts in Dashboards.

13. Save and Close your report.
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Charts add a visual element to reports, making it 
easier to decipher information or compare data.

Activity #7: Add a chart to a report
This hands-on exercise supports concepts taught in the video, Create reports with charts.

The end of the quarter is nearing, and you want to see how recently completed projects stuck to their budgets. Create a 
report that shows the planned cost vs. the actual cost for projects. You want to see only projects that were completed in 
the last quarter. Add a combination column chart using custom colors.

Use the space below to plan out filters, views, and groupings for this report.

Turn to the next page for the answer.
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Answer

Activity #7: Add a chart to a report

1. Select Reports from the Main Menu.

2. Click the New Report menu and select Project. 

3. In the Columns (View) tab, click Add Column.

4. Select Project > Planned Cost and summarize this 
column by Sum.

5. Click Add Column again.

6. Select Project > Actual Cost and summarize this column 
by Sum.

7. In the Groupings tab, set the report to group by Project 
> Name.

8. In the Filters tab, add two filter rules:

• Project > Status Equates With > Complete

• Project > Actual Completion Date > Last Quarter

9. In the Chart tab, choose Column for the chart type.

10. For the Left (Y) Axis, choose Project > Planned Cost.

11. For the Bottom (X) Axis, choose Project > Name.

12. Click the Combination Chart button and select Project > 
Actual Cost in the Value field.

13. Click the arrow next to the color box to change the 
Actual Cost color. Select one of the colors that appears or 
click the box in the lower-right corner to bring up the color 
palette.

14. Click on Save + Close. When prompted for a report 
name, call it “Planned vs Actual Cost by Project Completed 
Last Quarter.”
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Matrix reports display summarized information 
in a table format.

Activity #8: Create a matrix report
This hands-on exercise supports concepts taught in the video, Create a matrix report.

Create a matrix report that shows how many requests there are in each status, sorted by request queue. This gives you a 
quick snapshot of the amount of work coming in and how well you’re keeping up with it.

You want the request queues to appear on the row groupings. Status appears as the column groupings. Name your report 
“Requests by Status and Request Queue.”

Use the space below to plan out filters, views, and groupings for this report.

Turn to the next page for the answer.
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Answer

Activity #8: Create a matrix report

1. Select Reports from the Main 
Menu.

2. Click the New Report option 
and select Issue.

3. Go to the Groupings tab and 
click Switch to Matrix Grouping.

4. For Row Groupings, select 
Project > Name.

5. For Column Grouping, select 
Issue > Status.

6. Go to the Filters tab.

7. To make sure you see only 
requests in active request queues, 
add the following filter rules:

• Project > Status Equates 
With > Equal > Current

• Queue Definition > Is 
Public > Not Equal > None 
(this is how we know a 
project is actually a request 
queue, by the Queue 
Definition being assigned 
to one of the public 
options.)

8. Click on Save + Close. When 
prompted for a report name, 
type in “Requests by Status and 
Request Queue.”
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Seeing date information on a calendar grid can 
help you better visualize the work being done.

Activity #9: Create a custom calendar
This hands-on exercise supports concepts taught in the learning path, Create a basic custom calendar.

Create a customer calendar named “My Incomplete Work”. 

Include a calendar group named “Incomplete Tasks” showing all incomplete tasks assigned to you on Current projects. 
Select red as the color for these items. 

Include another calendar group named “Incomplete Issues” showing all incomplete issues assigned to you on Current 
projects. Select blue as the color for these items. 

Use the space below to plan out the settings for this report.

Turn to the next page for the answer.
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Answer

Activity #9: Create a 
custom calendar

1. Navigate to the Calendars area from the 
Main menu.

2. Click the New Calendar button and Name 
the calendar “My Incomplete Work.”

3. Under the first grouping, click Add advanced 
items.

4. In the Add items to the calendar window that 
pops up, name the group “Incomplete Tasks.”

5. Select red as the color.

6. Change the Date Field to Planned Dates.

7. Set the On the calendar, show field to End 
Date Only.

8. Set the Switch to actual dates when available 
field to No.

9. In the What would you like to add to the 
calendar? section, select Tasks.

10. Add three filter rules:

• Project > Status Equates With > Equal > 
Current

• Assignment Users > ID > Equal > $$USER.
ID

• Task > Is Complete > Equal > False

11. Click Save.

12. Create a second grouping by clicking Add to 
Calendar.

13. Under this grouping, click on Add advanced 
items.
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14. In the Add items to the calendar window that 
pops up, name the group “Incomplete Issues.”

15. Select blue as the color.

16. Change the Date Field to Planned Dates.

17. Set the On the calendar, show field to End Date 
Only.

18. Set the Switch to actual dates when available 
field to No.

19. In the What would you like to add to the 
calendar? section, select Issues.

20. Add the following three filter rules:

• Project > Status Equates With > Equal > 
Current

• Assignment Users > ID > Equal > $$USER.ID

• Issue > Is Complete > Equal > False

21. Click Save.

Because you used $$USER.ID in the filters, you can share 
this calendar with others and they will see their own 
incomplete tasks and issues.

Answer

Activity #9: Create a custom calendar, continued
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Share information with others with a one-time 
send or a repeating send.

Activity #10: Send a report
This hands-on exercise supports concepts taught in the video, Send and share reports.

Send a report to yourself every Monday at 5 am as an Excel spreadsheet. This is a great way to automatically collect 
weekly reports that you can later use to see trends.

Use the space below to plan out the criteria for sending the report.

Turn to the next page for the answer.
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Answer

Activity #10: Send a report

1. View any report you have created, and choose 
Send Report from the Report Actions menu.

2. Click the Repeating Deliveries tab.

3. Put your email address in the Send to field.

4. Provide an email subject.

5. Change the format to Excel.

6. Set Repeats to Weekly.

7. Set the Time to 5 am.

8. Set Repeats On to Monday.

9. Click Save.

Notice your new Repeating Delivery in the Repeating 
Deliveries panel on the right. You can set up multiple 
deliveries for a report and they all appear here.

DELE TE A DELIVERY

Select the delivery you just created and click Delete (next to the Save button).
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Gather the reports you need to do your work 
into a dashboard so it’s quick and easy to access.

Activity #11: Create a dashboard
This hands-on exercise supports concepts taught in the video, Create dashboards.

Create a dashboard with only one report in it—“Search Notes in This Project.” This is useful for quickly finding any update 
made on a project, even if there are thousands of updates to search through. This will search into update threads to 
quickly extract any updates that meet the criteria you specify in the prompts.

• Create this report by making a copy of the “Search Notes” report you created in the “Create a note report” activity 
(or use another report if you didn’t do that activity).

• Remove the Project Name prompt from the copy and rename the report “Search Notes in This Project.”

• Name the Dashboard “Search Notes.”

• Go to any project landing page and create a custom section for a dashboard.

• Note that when you search for notes in your custom section it will only show notes contained within the project 
you’re currently in.

Use the space below to plan out the steps to take to complete this activity.

Turn to the next page for the answer.



one.workfront.com 25

Answer

Activity #11: Create a dashboard

1. Run the report you created in the “Create a note 
report” activity.

2. Click Report Actions and select Copy. Workfront 
creates a new report named “Note Search (Copy).”

3. Go to Report Actions and select Edit. Click Report 
Settings and change the name to “Search Notes in 
This Project.”

4. Click Report Prompts and delete the Project > 
Name prompt from the list.

5. Check the Show Prompts in Dashboard box.

6. Click Done, then Save + Close. You now are looking 
at the Prompts screen of the report.

Next you’re going to use a shortcut to create a new 
dashboard and add this report to it.

7. Click Report Actions and select Add to Dashboard 
> New Dashboard.

8. Drag the report “Search Notes in This Project” to 
the Layout panel.

9. Notice that the name of the report becomes the 
name of the dashboard. Edit the name to just “Search 
Notes.”

10. Click Save + Close.

Now add the dashboard to a project page.

11. Go to any project. From the left panel menu, click 
the Add custom section icon.

12. In the Add a 
Dashboard field, type 

“Search Notes” and 
select the dashboard 
from the list.

13. In the Custom 
section title field, type 
in “Search Notes.”

14. Click Add new section.

15. From the left panel menu, find Search Notes. Click 
the dots to the left of the section name and drag it 
right below Updates.
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